↓ Advertise on Defender2 ↓

Home > Land Rover Customer Relations > EKA Code
Post Reply  Down to end
Page 5 of 5 <12345
Print this entire topic · 
spudfan



Member Since: 10 Sep 2007
Location: Co Donegal
Posts: 2852

Ireland 

Would it be too simplistic an answer to say put a fresh battery in the key fob?
If you need access to the interior of the vehicle you can push in the quarter light (small window to you and me) on the left hand side of the rear door. Once you have done this you should be able to insert your arm and manually open the rear door. I think there is a video up on this site showing how to put the window in. Just put pressure on it close to the rubber seal. Give it a quick shot with the palm of your hand or use a cloth, a piece of wood and a hammer. The window should not break. The hard part is getting it back into place again. 1982 88" 2.25 diesel
1992 110 200tdi csw -Zikali
2008 110 2.4 tdci csw-Zulu
2011 110 2.4 tdci csw-Masai

Post #839767 26th Jun 2020 12:29am
View user's profile Send private message View poster's gallery Reply with quote
SergeantJav



Member Since: 23 Jul 2015
Location: London
Posts: 56

United Kingdom 2015 Defender 110 Puma 2.2 XS CSW Corris Grey

I can get in and out....I have a key...yes I changed the battery....I now have a failed visit by Greenflag and an auto locksmith who couldn’t get his diagnostic machine to speak to the ECU for the security system...but the Landy showed no faults... I have also tried the reset resync sequence on other posts...nothing seems to work. So I have a very expensive Corgi toy on my drive Sad
The issue is the immobiliser has kicked in and no-one van give me the EKA code... it’s a 2015 Puma if anyone else has any ideas... the main dealer couldn’t suggest anything... Crying or Very sad

I am not even convinced the EKA code will work...

Anyone at land rover head office not furloughed read these posts ? Proud to own 110XS TDCi SW..previously 90XS Td5 SW

Post #839769 26th Jun 2020 12:53am
View user's profile Send private message View poster's gallery Reply with quote
blackwolf



Member Since: 03 Nov 2009
Location: South West England
Posts: 11484

United Kingdom 2007 Defender 110 Puma 2.4 DCPU Stornoway Grey

I have a suspicion that a 2015 Defender will have the non-Lucas 10AS that was fitted to the production runout vehicles and I don't think that these units even have an EKA code (the genuine Lucas ones all do even though the dealer network and JLR deny this). I'm sure by now you've tried the usual things like repeated presses of the fob buttons to resynch?

Post #839788 26th Jun 2020 8:46am
View user's profile Send private message View poster's gallery Reply with quote
SergeantJav



Member Since: 23 Jul 2015
Location: London
Posts: 56

United Kingdom 2015 Defender 110 Puma 2.2 XS CSW Corris Grey

Yep...tried the usual from other posts...plus the auto locksmith tried his diag software but couldn’t access the module... Big Cry

I think you might be correct and this could be a ticking time bomb for a lot of late defender owners... Crying or Very sad Proud to own 110XS TDCi SW..previously 90XS Td5 SW

Post #839792 26th Jun 2020 9:04am
View user's profile Send private message View poster's gallery Reply with quote
blackwolf



Member Since: 03 Nov 2009
Location: South West England
Posts: 11484

United Kingdom 2007 Defender 110 Puma 2.4 DCPU Stornoway Grey

If all else fails, get in touch with Pete Bell at BAS (search the forum or google for contact details) since I know that he can offer a solution which renders the 10AS completely redundant.

Post #839798 26th Jun 2020 9:21am
View user's profile Send private message View poster's gallery Reply with quote
SergeantJav



Member Since: 23 Jul 2015
Location: London
Posts: 56

United Kingdom 2015 Defender 110 Puma 2.2 XS CSW Corris Grey

Will try the main dealer again...but will bear in mind... Proud to own 110XS TDCi SW..previously 90XS Td5 SW

Post #839805 26th Jun 2020 9:43am
View user's profile Send private message View poster's gallery Reply with quote
SergeantJav



Member Since: 23 Jul 2015
Location: London
Posts: 56

United Kingdom 2015 Defender 110 Puma 2.2 XS CSW Corris Grey

Looks like the late defenders do indeed not have a code... my fault turned out to be a blown fuse...stopped the ECU for the alarm/immobiliser from talking to anything or responding hence no lock/unlock and wouldn’t let engine start... well worth a look if yours does similar.... break down truck had picked a few up that had same symptoms ....finally diagnosed by the main dealer...not sure why fuse blew....20amp Confused Located in main fuse box below steering wheel Neutral Proud to own 110XS TDCi SW..previously 90XS Td5 SW

Post #842366 7th Jul 2020 5:48pm
View user's profile Send private message View poster's gallery Post Reply
Post Reply  Back to top
Page 5 of 5 <12345
All times are GMT + 1 Hour

Jump to  
Previous Topic | Next Topic >
Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Site Copyright © 2006-2020 Futuranet Ltd & Martin Lewis