↓ Advertise on Defender2 ↓

Home > V8 > Temperature Gauge
Post Reply  Down to end
Page 1 of 1
Print this entire topic · 
BaronDefenders



Member Since: 28 Jun 2019
Location: London/Cotswolds
Posts: 795

United Kingdom 2004 Defender 90 Td5 SW Santorini Black
Temperature Gauge
My V8’s temperature gauge works, but never actually reaches the mid-point. It will get close to the first thin line before the thermostat opens, then settling on the first thick line. The photo below is the gauge after a two hour drive at 60mph.

Any ideas as to how I can get the gauge reading correctly?



Click image to enlarge
 Charlie

1949 Series 1 80 (SOLD)
2002 Td5 90 (SOLD)
2008 Freelander 2 (SOLD)

1958 Series 2 88 Pastel Green (2019 LR Legends Best Restored)
1983 V8 110 Limestone (Previously owned by Tom Sheppard MBE)
2004 Td5 90 Santorini Black (Td5INSIDE Powered & Rebuilt by CSK)
2012 Puma 110 Zermatt Silver (Overlanding Build)

Instagram: @BaronDefenders
Post #954632 5th Jun 2022 6:31pm
View user's profile Send private message View poster's gallery Reply with quote
mikeh501



Member Since: 07 Jan 2013
Location: United Kingdom
Posts: 1142

United Kingdom 
Mismatch between sender and gauge?
Post #954669 6th Jun 2022 6:58am
View user's profile Send private message View poster's gallery Reply with quote
BaronDefenders



Member Since: 28 Jun 2019
Location: London/Cotswolds
Posts: 795

United Kingdom 2004 Defender 90 Td5 SW Santorini Black
As in it has the wrong sender fitted in the engine? Charlie

1949 Series 1 80 (SOLD)
2002 Td5 90 (SOLD)
2008 Freelander 2 (SOLD)

1958 Series 2 88 Pastel Green (2019 LR Legends Best Restored)
1983 V8 110 Limestone (Previously owned by Tom Sheppard MBE)
2004 Td5 90 Santorini Black (Td5INSIDE Powered & Rebuilt by CSK)
2012 Puma 110 Zermatt Silver (Overlanding Build)

Instagram: @BaronDefenders
Post #954670 6th Jun 2022 7:12am
View user's profile Send private message View poster's gallery Reply with quote
mikeh501



Member Since: 07 Jan 2013
Location: United Kingdom
Posts: 1142

United Kingdom 
Yes or wrong gauge for sender etc.
Post #954671 6th Jun 2022 7:23am
View user's profile Send private message View poster's gallery Reply with quote
BaronDefenders



Member Since: 28 Jun 2019
Location: London/Cotswolds
Posts: 795

United Kingdom 2004 Defender 90 Td5 SW Santorini Black
Righto. I’ve ordered a new sender in case. It’s the original factory gauge. Charlie

1949 Series 1 80 (SOLD)
2002 Td5 90 (SOLD)
2008 Freelander 2 (SOLD)

1958 Series 2 88 Pastel Green (2019 LR Legends Best Restored)
1983 V8 110 Limestone (Previously owned by Tom Sheppard MBE)
2004 Td5 90 Santorini Black (Td5INSIDE Powered & Rebuilt by CSK)
2012 Puma 110 Zermatt Silver (Overlanding Build)

Instagram: @BaronDefenders
Post #954672 6th Jun 2022 7:30am
View user's profile Send private message View poster's gallery Reply with quote
mediamab



Member Since: 01 Dec 2021
Location: Matlock
Posts: 58

United Kingdom 2003 Defender 90 2.5 TD SW Epsom Green
Hi, I’m having exactly the same issue with my v8 with original gauge. Did the new sender help? Do you know the part number?
Many thanks!!
Post #1021053 13th Jan 2024 6:47pm
View user's profile Send private message View poster's gallery Reply with quote
edo



Member Since: 20 Aug 2018
Location: Surrey
Posts: 339

United Kingdom 
Thread resurection!

I have similar. Needle only just registers. Thermostat is good and car gets up to temp ok. Changed sender no joy....
Post #1023426 3rd Feb 2024 11:47am
View user's profile Send private message View poster's gallery Post Reply
Post Reply  Back to top
Page 1 of 1
All times are GMT

Jump to  
Previous Topic | Next Topic >
Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Site Copyright © 2006-2024 Futuranet Ltd & Martin Lewis
DEFENDER2.NET RSS Feed - All Forums