↓ Advertise on Defender2 ↓

Home > In Car Electronics > HELP! Just fitted WIPAC LED indicators
Post Reply  Down to end
Page 1 of 1
Print this entire topic · 
jeffersj



Member Since: 23 Jan 2015
Location: Near Preston
Posts: 282

United Kingdom 1996 Defender 90 300 Tdi HT Bronze Green
HELP! Just fitted WIPAC LED indicators

Just fitted Wipac LEDS and adjustable flasher unit to a 96 300TDi , did not have to change wiring around as it was re-wired 2012. Also only have trailer buzzer so no adjustment was needed to the unit.

I tested each one as I fitted them and all was OK but when I have put everything back together and pushed wires out of the way to tidy them now all I have are 4-way flashers no matter which indicator I use?. Tried using the adjuster knob but made no difference.

Could I have kinked a wire or something, I have checked each connection and all is fine. One thing I noticed is that when I put the left indicator on the right side repeater seems faint (LED also) but all other flash at normal speed.


Any clues please as i am stuck? Jeff
Ex 1968 Series 2A
Ex 90 TD5
Ex D3
Ex D4

Post #796699 4th Oct 2019 3:27pm
View user's profile Send private message View poster's gallery Reply with quote
LandRoverAnorak



Member Since: 17 Jul 2011
Location: Surrey
Posts: 7213

United Kingdom 2013 Defender 110 Puma 2.2 USW Orkney Grey

Sounds very much like you've dislodged an earth wire. Time to re-trace your steps, unfortunately. Darren

2013 Defender 110 USW XS
2013 Discovery 4 XS

"You came in that thing? You're braver than I thought!" - Princess Leia

MY 110 USW BUILD THREAD - MY 200tdi 90 BUILD THREAD - Instagram: @landroveranorak

Post #796703 4th Oct 2019 3:37pm
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
gilarion



Member Since: 05 Dec 2013
Location: Wales and Manchester
Posts: 4645

Wales 2007 Defender 90 Other CSW Trident Green

It could be the known problem on a 300Tdi. And there is a fix, firstly take out the instrument flasher warning bulb, easy to do just undo the two screws on the warning light cluster and remove the little bulb. Next try your indicators with the warning light removed right and left they should work perfectly, if this is the case it will be due to an earth return through the loom from the indicators to the warning light (which it will be).

If all works with the warning bulb removed then you will need the new style warning bulb that has an earth lead attached, just connect the lead to a good earth and then put the new bulb in the warning light cluster and the job will be a good un! And everything will work as it should.

The Famous Bolt-On Bits RDX LED Fix Kit now available on eBay.

The issue mainly affects older cars like the 200Tdi & 300Tdi after upgrading your indicators to LED (ours and others), when you indicate left the right side also glows (usually not at full brightness) and same when you indicate right the left side also comes on.

Generally, this is caused by an earth leakage somewhere in the system, we have developed this simple fix to save you the hassle of locating the leak. If you remove your dashboard indicator signal light (not the trailer light) and it fixes the problem then this kit will sort out that fault.

Take your dashboard indicator signal light out and replace this with our signal light give it a good earth (use an instrument earth point), issue solved.

https://www.ebay.co.uk/itm/RDX-Earth-Fix-K...Swz39c32ru For those who like Welsh Mountains and narrow boats have a look at my videos and photos at..

http://www.youtube.com/user/conwy1

Post #796704 4th Oct 2019 3:44pm
View user's profile Send private message View poster's gallery Reply with quote
jeffersj



Member Since: 23 Jan 2015
Location: Near Preston
Posts: 282

United Kingdom 1996 Defender 90 300 Tdi HT Bronze Green

Thanks chaps, as you say its an earth problem, did the RDX thing of taking warning light bulb out and everything works, so will have to by the bulb with earth attached, Big Cry Jeff
Ex 1968 Series 2A
Ex 90 TD5
Ex D3
Ex D4

Post #796719 4th Oct 2019 4:57pm
View user's profile Send private message View poster's gallery Reply with quote
jeffersj



Member Since: 23 Jan 2015
Location: Near Preston
Posts: 282

United Kingdom 1996 Defender 90 300 Tdi HT Bronze Green

Just wondering if not having an indicator warning light is a MOT fail ? I could live without the bulb intact but have ordered the earth fix kit. Jeff
Ex 1968 Series 2A
Ex 90 TD5
Ex D3
Ex D4

Post #796794 5th Oct 2019 10:59am
View user's profile Send private message View poster's gallery Reply with quote
jeffersj



Member Since: 23 Jan 2015
Location: Near Preston
Posts: 282

United Kingdom 1996 Defender 90 300 Tdi HT Bronze Green
Update

Well I fitted the Bolt-on-bits bulb and secured it ti a good earth and everything worked fine. Decided to attach a trailer just to be sure and back to square one i.e. left indicator worked fine but right indicator set 4way flashers off, tried adjusting the flasher relay unit to no avail.

Checked all connections again and even with trailer detached all 4 flashers going at once. So had a fiddle with the bolt-on-bits bulb and suddenly all was fine. It seems that unless you get this bulb in the right way up then problems return.

Took the motor out last night in the torrential rain, all was fine for a few minutes then problem returned-left indicators OK but right indicator cause 4-way flashers to come on???? During this problem the new BOB bulb did not light up.

So back to the drawing board! Big Cry Jeff
Ex 1968 Series 2A
Ex 90 TD5
Ex D3
Ex D4


Last edited by jeffersj on 11th Oct 2019 9:38am. Edited 1 time in total

Post #797527 10th Oct 2019 7:34am
View user's profile Send private message View poster's gallery Reply with quote
Balvaig



Member Since: 19 Feb 2016
Location: Fife
Posts: 450

Scotland 2016 Defender 90 Puma 2.2 Landmark LE Corris Grey

I don't know this unit, but I would start by checking that the BoB bulb hasn't blown.

Post #797544 10th Oct 2019 10:59am
View user's profile Send private message View poster's gallery Reply with quote
jeffersj



Member Since: 23 Jan 2015
Location: Near Preston
Posts: 282

United Kingdom 1996 Defender 90 300 Tdi HT Bronze Green

Thanks Balvaig. Had a good look today but this is a tiny green bulb so can not see the filament, doubt if I could test it off the unit as there is no way to connect wires to it although it has its own earth wire and the live is picked up by contacts to the mother board in the warning light console, like the other bulbs? Jeff
Ex 1968 Series 2A
Ex 90 TD5
Ex D3
Ex D4

Post #797549 10th Oct 2019 11:22am
View user's profile Send private message View poster's gallery Reply with quote
Balvaig



Member Since: 19 Feb 2016
Location: Fife
Posts: 450

Scotland 2016 Defender 90 Puma 2.2 Landmark LE Corris Grey

Sorry. With you saying about getting the bulb in the right way up I guessed it was a replaceable bulb.
Hopefully someone will be along who knows the unit

Post #797559 10th Oct 2019 12:52pm
View user's profile Send private message View poster's gallery Post Reply
Post Reply  Back to top
Page 1 of 1
All times are GMT

Jump to  
Previous Topic | Next Topic >
Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Site Copyright © 2006-2019 Futuranet Ltd & Martin Lewis