↓ Advertise on Defender2 ↓

Home > Td5 > Running flat/ underpowered
Post Reply  Down to end
Page 1 of 1
Print this entire topic · 
Martin 01



Member Since: 13 Feb 2012
Location: East Yorkshire
Posts: 483

Running flat/ underpowered

Defender seems to be running rather flat with no sort of go in it.
Did the multimeter test on the MAF last night & seemed to be showing less than 1v at idle.
Borrowed a MAF from my friends TD5 that is running fine & fitted to mine but still seems to be running the same.
It had a new harness few months back when I serviced it & it had a new VDO fuel pump fitted few weeks ago.
Also recently cleaned the MAP sensor.


Anyone any ideas what to check for next ?


Last edited by Martin 01 on 5th Jan 2019 4:53pm. Edited 1 time in total

Post #749366 5th Jan 2019 3:22pm
View user's profile Send private message View poster's gallery Reply with quote
Martin 01



Member Since: 13 Feb 2012
Location: East Yorkshire
Posts: 483

Just ran a test on the MAF with multimeter & it’s showing 2v and going up when revving the engine.
Obviously my MAF was knackered.
Still doesn’t seem as lively as when I had it mapped.

Will it have gone into a learning mode whilst mine was knackered ?
Had it unplugged for couple of days to, to see if that made any difference.

Post #749384 5th Jan 2019 4:52pm
View user's profile Send private message View poster's gallery Reply with quote
bankz5152



Member Since: 02 Feb 2017
Location: South London/North Kent
Posts: 1314

2004 Defender 110 Td5 DCPU Epsom Green

Learning mode?

So youve driven it with the maf disconected? Any change?

Ideally you need it pluged into diagnostics.

How flat do you mean? Could be in limp mode. Instagram @defender_ventures

Post #749388 5th Jan 2019 5:00pm
View user's profile Send private message View poster's gallery Reply with quote
dorsetsmith



Member Since: 30 Oct 2011
Location: South West
Posts: 3317

are getting 12v supply to maf :?:

Post #749394 5th Jan 2019 5:16pm
View user's profile Send private message View poster's gallery Reply with quote
Martin 01



Member Since: 13 Feb 2012
Location: East Yorkshire
Posts: 483

Yes got 12v coming in. It’s actually around 14 when running.
Is the only way to get it out of limp mode to get a diagnostic tool plugged into it & code cleared ?
Car does have a bit more go in it but doesn’t seem to go as well as when it was remapped by Alive.
Maybe need a quick trip to go see Gary @ Alive.

Post #749408 5th Jan 2019 5:54pm
View user's profile Send private message View poster's gallery Reply with quote
dorsetsmith



Member Since: 30 Oct 2011
Location: South West
Posts: 3317

quick trip to go see Gary @ Alive.

Post #749411 5th Jan 2019 6:12pm
View user's profile Send private message View poster's gallery Reply with quote
Martin 01



Member Since: 13 Feb 2012
Location: East Yorkshire
Posts: 483

Wink Thumbs Up

Post #749415 5th Jan 2019 6:47pm
View user's profile Send private message View poster's gallery Reply with quote
drinkdrinkdrop



Member Since: 13 Sep 2016
Location: Surrey
Posts: 76

United Kingdom 

Wastegate actuator is worth checking with those symptoms

Post #750510 11th Jan 2019 11:57am
View user's profile Send private message View poster's gallery Reply with quote
grafty99



Member Since: 15 Aug 2012
Location: North Devon
Posts: 3847

United Kingdom 2002 Defender 90 Td5 HT Caledonian Blue

+1 for checking wastegate is moving freely Thumbs Up 2002 90 Td5 Station Wagon
1990 Vogue SE
Triumph Tiger Explorer 1200
Defender Thread http://www.defender2.net/forum/topic50767.html
RRC Thread http://www.defender2.net/forum/topic54492.html
Instagram http://www.instagram.com/george_grafton

Post #750580 11th Jan 2019 6:52pm
View user's profile Send private message View poster's gallery Reply with quote
Martin 01



Member Since: 13 Feb 2012
Location: East Yorkshire
Posts: 483

All sorted now thanks fellas Very Happy Very Happy

Fitted new MAF sensor & now showing 2v at idle.
Rang Gary @ Alive to arrange to take it in to be looked at.
Got to Alive & they checked everything over & all seemed good until he discovered my map had been wiped from the ECU when my local guy updated my software. Local guy thought he was doing me a good deed by updating everything after sorting my 3 amigos problem out.
Anyway Gary has restored my map with more updated version & now it's running like a dream again.
Has the oooomph back & pulls strong again.
Thanks for all of your advice, much appreciated Thumbs Up

Post #750621 11th Jan 2019 9:28pm
View user's profile Send private message View poster's gallery Reply with quote
roel



Member Since: 08 Aug 2009
Location: Lelystad
Posts: 1572

Netherlands 2003 Defender 90 Td5 PU Caledonian Blue

A MAF is not only broken if it is dead. I had one that gave about 40% lower readings.

Reading your symptoms I don't think it is the MAF. But I don't know what else it can be. So borrow a Nanocom and do a test drive and look at the readings.

A td5 does not stay in limpmode. Everytime you start up the same problem has to be there to get in limp mode again. Roel

1984 90 2.5 na Diesel - RR V8 (1994-2001)
1997 Camel Trophy Discovery 300TDI (2001-2009)
2005 G4 Discovery III 4.4 V8 (2008-2018) It's gone but it still hurts.
2003 90 Td5 (2009-now)

Post #750622 11th Jan 2019 9:29pm
View user's profile Send private message View poster's gallery Reply with quote
Martin 01



Member Since: 13 Feb 2012
Location: East Yorkshire
Posts: 483

Read above my reply Roel.
Problem all sorted now with explanation above. Thumbs Up

Post #750646 11th Jan 2019 10:59pm
View user's profile Send private message View poster's gallery Reply with quote
4RF RDS



Member Since: 19 Jul 2015
Location: Ottawa
Posts: 488

Canada 2000 Defender 110 Td5 XS CSW Epsom Green

Oh that Roel, always behind the times Rolling with laughter Bow down 2010 Range Rover MkIII Autobiography Super Charged (Beast)
2003 Range Rover Mk III (Desmond FitzWilliam)
2000 Defender 110 CSW TD5 (CTX)
1992 Range Rover Classic (Lizzy)
1972 Series III 300 Tdi (Stanwood)

Every normal man must be tempted at times to spit on his hands, hoist the black flag, and begin to slit throats.
H. L. Mencken (1880 - 1956)

Post #750658 12th Jan 2019 12:51am
View user's profile Send private message View poster's gallery Reply with quote
roel



Member Since: 08 Aug 2009
Location: Lelystad
Posts: 1572

Netherlands 2003 Defender 90 Td5 PU Caledonian Blue

Looks like we were typing at the same time. Mr. Green Roel

1984 90 2.5 na Diesel - RR V8 (1994-2001)
1997 Camel Trophy Discovery 300TDI (2001-2009)
2005 G4 Discovery III 4.4 V8 (2008-2018) It's gone but it still hurts.
2003 90 Td5 (2009-now)

Post #751000 13th Jan 2019 7:09pm
View user's profile Send private message View poster's gallery Post Reply
Post Reply  Back to top
Page 1 of 1
All times are GMT + 1 Hour

Jump to  
Previous Topic | Next Topic >
Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Site Copyright © 2006-2019 Futuranet Ltd & Martin Lewis