↓ Advertise on Defender2 ↓

Home > Modifications & Maintenance (L663) > Retrofit 11.4 Pivi Display
Post Reply  Down to end
Page 4 of 4 <1234
Print this entire topic · 
abyss



Member Since: 30 Sep 2017
Location: Melbourne
Posts: 22

Australia 
Tried everything, reset the pivi like 10 times and checked the wiring thousands times. No luck only get blank screen.

So I returned the wiring back to original and connected back to my 10” screen and ccf back to Panasonic 10”. Still blank screen. Even restored all CCF in the Gap G4 tool, still no luck.

So frustrated and now battery is low so hooked up battery charger and try again tomorrow. Evil or Very Mad
Post #1036889 9th Jun 2024 9:51am
View user's profile Send private message View poster's gallery Reply with quote
mmbanf



Member Since: 16 Mar 2021
Location: Milano
Posts: 135

Italy 
HI ,
It's very strange that the original screen doesn't work...
When you did the work, did you first disconnect the battery, before disconnecting the various connectors?
Have you checked the fuse 51 rear fuse box?
When you connect the gap, do the troubleshooting, what does it say?
Post #1036898 9th Jun 2024 11:12am
View user's profile Send private message View poster's gallery Reply with quote
Clark4x4



Member Since: 19 Jun 2023
Location: Madrid
Posts: 26

Spain 
Hi Abyss,

I can't find anything wrong in your steps. I did the same. only issue in my case is module still has the donor VIN, but all working fine.

I'm trying to upgrade to 13.1 version, and I have the same issue. Curioussly in my upgrade to 11.4 used GAP G3 and now trying with G4... but not sure if is related.

Have you check errors? maybe give you a clue.

Important!!! whatever you do, don't let car drain battery!!! I speak from my personal experience... I end on dealer and was a paint just move car... Keep battery up!!!

So, I can't give you a solution, I'm stuck is similar point, only change is GAP version. In my upgrade to 11.4 I was able to perform a CCF relearn but I got same error than you with G4.

I'll try to investigate, but maybe at the end PAthfinder is needed, Don't know...

Regards
Post #1036899 9th Jun 2024 11:21am
View user's profile Send private message View poster's gallery Reply with quote
mmbanf



Member Since: 16 Mar 2021
Location: Milano
Posts: 135

Italy 
Hi Clark,
there is no 13.1 screen on the multican 641,
which ccf are you changing?
I imagine you are using a used screen.
Post #1036901 9th Jun 2024 11:33am
View user's profile Send private message View poster's gallery Reply with quote
abyss



Member Since: 30 Sep 2017
Location: Melbourne
Posts: 22

Australia 
Thanks Clark. When I did the 11.6” CCF in Gap G4 for the first time the battery was low. Maybe that was the issue?

The battery is getting charged til tomorrow. Hopefully I have some good news for you all.
Post #1036902 9th Jun 2024 11:34am
View user's profile Send private message View poster's gallery Reply with quote
Clark4x4



Member Since: 19 Jun 2023
Location: Madrid
Posts: 26

Spain 
For my surprise, I found it:



Click image to enlarge


Yeah, is weird, 13.3...
Post #1036903 9th Jun 2024 11:35am
View user's profile Send private message View poster's gallery Reply with quote
G4R1



Member Since: 17 Aug 2020
Location: Barnet/Limassol
Posts: 131

United Kingdom 


It looks like that they had the similar issue with blank screen and after full power cycle the screen turned on!! 3.0L MHVE D200 S Pangea Green+Black Pack
Adv. + Off-Road and Family Packs
Post #1036963 9th Jun 2024 6:36pm
View user's profile Send private message View poster's gallery Reply with quote
abyss



Member Since: 30 Sep 2017
Location: Melbourne
Posts: 22

Australia 
Thanks G4R1 !!!

That gave me a bit of hope. Managed to fully charger car battery now will leave it locked for 24 hours. Fingers crossed 🤞
Post #1036990 10th Jun 2024 4:51am
View user's profile Send private message View poster's gallery Reply with quote
StromC



Member Since: 30 Jan 2023
Location: Rockville
Posts: 8

United States 
Do I need a wiring adaptor if I am trying to go from the 11.4" to the 13.1" screen? Thank you!
Post #1037115 11th Jun 2024 2:11pm
View user's profile Send private message View poster's gallery Reply with quote
Clark4x4



Member Since: 19 Jun 2023
Location: Madrid
Posts: 26

Spain 
About wiring adapter... short answer: Not sure.

I mean:

I search in electrical wiring in a new Range Rover Sport, and all pins are the same except 3 missing (comparing with 11.4" in the right)
pins 6 and 7 are power supply for haptics. Are necesary?, not sure...
and pin 4 is sort of sound exit for haptics. Again, not sure if are necesary...


Click image to enlarge


I need to find the mood to dismantle again and test with a power cycle this time...

Regards
Post #1037146 11th Jun 2024 6:10pm
View user's profile Send private message View poster's gallery Reply with quote
Clark4x4



Member Since: 19 Jun 2023
Location: Madrid
Posts: 26

Spain 
abyss wrote:
Thanks G4R1 !!!

That gave me a bit of hope. Managed to fully charger car battery now will leave it locked for 24 hours. Fingers crossed 🤞


At the end power cycle solve the issue?
Post #1037148 11th Jun 2024 6:11pm
View user's profile Send private message View poster's gallery Reply with quote
StromC



Member Since: 30 Jan 2023
Location: Rockville
Posts: 8

United States 
Clark4x4 wrote:
About wiring adapter... short answer: Not sure.

I mean:

I search in electrical wiring in a new Range Rover Sport, and all pins are the same except 3 missing (comparing with 11.4" in the right)
pins 6 and 7 are power supply for haptics. Are necesary?, not sure...
and pin 4 is sort of sound exit for haptics. Again, not sure if are necesary...


Click image to enlarge


I need to find the mood to dismantle again and test with a power cycle this time...

Regards


Thanks for the information. I may give it a try. My understanding is that there are some minimal modifications needed to the bracket. Will try with the current wiring.
Post #1037151 11th Jun 2024 6:37pm
View user's profile Send private message View poster's gallery Reply with quote
abyss



Member Since: 30 Sep 2017
Location: Melbourne
Posts: 22

Australia 
Clark4x4 wrote:
abyss wrote:
Thanks G4R1 !!!

That gave me a bit of hope. Managed to fully charger car battery now will leave it locked for 24 hours. Fingers crossed 🤞


At the end power cycle solve the issue?


No luck. I did the power cycle with both 10.8" screen re-installed with ccf 10.8" and 11.4" reinstalled with ccf 11.6". I took photo with wiring position and 100% no issue with the connection. I still got blank screen. I even drove the car for a day with blank screen hoping the car will sort of reset itself but still blank screen.

I've booked in dealer to look at it next week. Now I'm thinking if I should go back with factory 10.8" at least they need it make it worked again or 11.4" pretend the car came with 11.4"?
Post #1037194 12th Jun 2024 1:02am
View user's profile Send private message View poster's gallery Reply with quote
Clark4x4



Member Since: 19 Jun 2023
Location: Madrid
Posts: 26

Spain 
Hard to say, I guess depend of dealers aptitude... you could tell them the true and go with new screen and old one just in case the dealer only want to work with original... don't know.

Did you look for errors with GAP tool?

Is very extrange, it must work. The only point is your screen was a brand new and maybe process is diferent, I'm just assuming...

Good luck and keep us informed, I'm curious about your case!!

Regards
Post #1037197 12th Jun 2024 6:53am
View user's profile Send private message View poster's gallery Reply with quote
abyss



Member Since: 30 Sep 2017
Location: Melbourne
Posts: 22

Australia 
Thanks Clark.

I think the only potential issue was when I did the CCF change the car dash did say “Low battery and start the car” but I ignored it. Could be the ecu didn’t like the low battery.

Will you posted.
Post #1037211 12th Jun 2024 9:58am
View user's profile Send private message View poster's gallery Post Reply
Post Reply  Back to top
Page 4 of 4 <1234
All times are GMT + 1 Hour

Jump to  
Previous Topic | Next Topic >
Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Site Copyright © 2006-2024 Futuranet Ltd & Martin Lewis
DEFENDER2.NET RSS Feed - All Forums