↓ Advertise on Defender2 ↓

Home > Td5 > Juddering speedo needle
Post Reply  Down to end
Page 1 of 1
Print this entire topic · 
diesel_jim



Member Since: 13 Oct 2008
Location: hiding
Posts: 4195

United Kingdom 2006 Defender 110 Td5 SW Epsom Green
Juddering speedo needle

Strange one this, I suspect it may be an earth issue;

Turn ignition on (or engine off), speedo needle "judders", almost like a relay vibrating for approx 5 seconds.

It's sat at 0mph on the "rest" pin/needle thing, it just vibrates, probably raises just off of the rest pin.

Any ideas?

Post #693066 13th Mar 2018 1:41pm
View user's profile Send private message View poster's gallery Reply with quote
Tdi4



Member Since: 24 Oct 2014
Location: Houten
Posts: 371

Netherlands 2008 Defender 110 Puma 2.4 CSW Stornoway Grey

I'am getting old Rolling with laughter

I know I've had the same problem but I can't recollect how I solved it. I need a Idea .

Best guess, battery or loose connection to the battery.

But if I remember I'll post in this thread a defender from 1984 pretending to be a puma with a touch of Range Rover

Post #693073 13th Mar 2018 2:34pm
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
diesel_jim



Member Since: 13 Oct 2008
Location: hiding
Posts: 4195

United Kingdom 2006 Defender 110 Td5 SW Epsom Green

It has 2x brand new optimas fitted (although it did it before with the old optimas), bolted up nice and tight, so I think I can rule that out.

Post #693106 13th Mar 2018 6:52pm
View user's profile Send private message View poster's gallery Post Reply
Post Reply  Back to top
Page 1 of 1
All times are GMT + 1 Hour

Jump to  
Previous Topic | Next Topic >
Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Site Copyright © 2006-2018 Futuranet Ltd & Martin Lewis