↓ Advertise on Defender2 ↓

Home > Td5 > 110 wont turn off with key when lights are on
Post Reply  Down to end
Page 1 of 1
Print this entire topic · 
davidblythe



Member Since: 27 Apr 2019
Location: sutton
Posts: 11

United Kingdom 
110 wont turn off with key when lights are on

bought this ex utility 110 in May to use for work and am learning to work on them

with the lights on and engine running, when i come to stop the van, the ignition keys doesnt cut the engine, turning the lights off does

ignition keys works fine when the lights are not on, any ideas

pics of truck


Click image to enlarge



Click image to enlarge



Click image to enlarge

Post #808876 5th Jan 2020 7:00pm
View user's profile Send private message View poster's gallery Reply with quote
ickle



Member Since: 22 Jul 2010
Location: South Vendee
Posts: 1290

France 2008 Defender 110 Puma 2.4 CSW Alpine White

Faulty ignition switch (common) or bad earth somewhere (also common) multipoint on bulkhead, strap bulkhead to chassis as std, worth checking both and adding some more.

HTH Keith

Post #808877 5th Jan 2020 7:03pm
View user's profile Send private message View poster's gallery Reply with quote
Rkcorry



Member Since: 23 Jan 2017
Location: Northern Ireland
Posts: 179

A quick check of the rear light clusters may also be an idea, corrosion or wrong bulb in the brake lights, I had something similar on an ex utilities, given the lights have already been upgraded Whistle definitely worth a look.

Post #808891 5th Jan 2020 7:56pm
View user's profile Send private message View poster's gallery Reply with quote
blackwolf



Member Since: 03 Nov 2009
Location: South West England
Posts: 10453

United Kingdom 2007 Defender 110 Puma 2.4 DCPU Stornoway Grey

Does the engine stop if you have taken the key out then dip the clutch? Many utility vehicles are fitted with runlock systems to allow the vehicle to be locked with the engine running, and whilst you should need to press a switch to engage the system there are fault conditions which could activate it without. I wouldn't expect turning the lights on to stop it though.

Post #808942 5th Jan 2020 9:58pm
View user's profile Send private message View poster's gallery Reply with quote
s55shh



Member Since: 30 Dec 2019
Location: staffs
Posts: 13

United Kingdom 

common fault on S1 Lotus Elise when the cigar lighter is wired up back to front.

Post #808943 5th Jan 2020 9:59pm
View user's profile Send private message View poster's gallery Reply with quote
davidblythe



Member Since: 27 Apr 2019
Location: sutton
Posts: 11

United Kingdom 

blackwolf wrote:
Does the engine stop if you have taken the key out then dip the clutch? Many utility vehicles are fitted with runlock systems to allow the vehicle to be locked with the engine running, and whilst you should need to press a switch to engage the system there are fault conditions which could activate it without. I wouldn't expect turning the lights on to stop it though.


will try in the morning

Post #808951 5th Jan 2020 10:37pm
View user's profile Send private message View poster's gallery Reply with quote
Rkcorry



Member Since: 23 Jan 2017
Location: Northern Ireland
Posts: 179

s55shh wrote:
common fault on S1 Lotus Elise when the cigar lighter is wired up back to front.



Something similar here. If the brake pedal has any bearing on this, it is worth checking the rear clusters, as current is travelling to the ignition via the contacts/bulb.

Post #809020 6th Jan 2020 3:38pm
View user's profile Send private message View poster's gallery Reply with quote
Phil VM2.5



Member Since: 28 Mar 2012
Location: Limelette
Posts: 168

Belgium 2012 Defender 110 Puma 2.2 SW Keswick Green

Hi,
Funny I did have the same with my td4 !
Do not know why but seems to go better after clean the ground cable attached to the transfert box
Philippe current : defender 110 sw 2.2 puma 2012 and 180.000km today
before :
Range Rover VM2.5 engine from 1992 to 2012 nearly 500.000km
One ten 1988 to 1992
1987 BMW GS80
One Ten from 1984 to 1987
One Ten from 1983 to 1984
Serie 3 109 from 1980 to 1983
from 1974 Jeep CJ3B and CJ6

Post #809216 7th Jan 2020 4:00pm
View user's profile Send private message View poster's gallery Reply with quote
Hazza



Member Since: 10 Jan 2011
Location: North Yorkshire / Leeds
Posts: 152

United Kingdom 1990 Defender 110 200 Tdi HT Bronze Green

I had the same issue on the td5, turned out that the wiring harness that runs through the front wing had chafed through and was shorting. 2001 Defender 90 TD5 'Dotty' NOW DECEASED
1990 Defender 110 200TDI Camper
Home built 13hp Off Road Go-Kart - 40mph tops + no suspension...FUN!

Post #810522 16th Jan 2020 10:49am
View user's profile Send private message View poster's gallery Send e-mail Post Reply
Post Reply  Back to top
Page 1 of 1
All times are GMT

Jump to  
Previous Topic | Next Topic >
Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Site Copyright © 2006-2020 Futuranet Ltd & Martin Lewis